[MODDB] phpBB Syntax Highlighter - 1.0.12

Moderator: Moderators

<<

UseLess

User avatar

Village Idiot
Village Idiot

Posts: 272

Joined: Thu Jan 08, 2009 9:57 pm

Location: North East UK

Post Wed Dec 15, 2010 5:56 pm

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Greetings,

Does
  Code:
[version /]
work? Using the version BBCode tag will result in something similar to the following:
[ Hide ]
BBCode (Hooker) Version: 2.0.15 Release: 0 Build: 45
Oh! Err... BBCodes without adding custom ones...
The following BBCode tags are supported: version, quoter, syntax, spoil, spoiler, hide, marquee, marq, s, hr, sub, sup, ovl, table, countdown, youtube, rquote, nfo, gamertag

(224) Supported Syntaxes: 4cs, 6502acme, 6502kickass, 6502tasm, 68000devpac, abap, actionscript, actionscript3, ada, algol68, apache, applescript, apt_sources, arm, asm, asp, asymptote, autoconf, autohotkey, autoit, avisynth, awk, bascomavr, bash, basic4gl, bf, bibtex, blitzbasic, bnf, boo, c, c_loadrunner, c_mac, caddcl, cadlisp, cfdg, cfm, chaiscript, cil, clojure, cmake, cobol, coffeescript, cpp, cpp-qt, csharp, css, cuesheet, d, dcl, dcpu16, dcs, delphi, diff, div, dos, dot, e, ecmascript, eiffel, email, epc, erlang, euphoria, f1, falcon, fo, fortran, freebasic, freeswitch, fsharp, gambas, gdb, genero, genie, gettext, glsl, gml, gnuplot, go, groovy, gwbasic, haskell, haxe, hicest, hq9plus, html4strict, html5, icon, idl, ini, inno, intercal, io, j, java, java5, javascript, jquery, kixtart, klonec, klonecpp, latex, lb, ldif, lisp, llvm, locobasic, logtalk, lolcode, lotusformulas, lotusscript, lscript, lsl2, lua, m68k, magiksf, make, mapbasic, matlab, mirc, mmix, modula2, modula3, mpasm, mxml, mysql, nagios, netrexx, newlisp, nsis, oberon2, objc, objeck, ocaml, ocaml-brief, octave, oobas, oorexx, oracle11, oracle8, oxygene, oz, parasail, parigp, pascal, pcre, per, perl, perl6, pf, php, php-brief, phpbb, pic16, pike, pixelbender, pli, plsql, postgresql, povray, powerbuilder, powershell, proftpd, progress, prolog, properties, providex, purebasic, pycon, pys60, python, q, qbasic, rails, rebol, reg, rexx, robots, rpmspec, rsplus, ruby, sas, scala, scheme, scilab, sdlbasic, smalltalk, smarty, spark, sparql, sql, stonescript, systemverilog, tcl, teraterm, text, thinbasic, tsql, typoscript, unicon, upc, urbi, uscript, vala, vb, vbnet, vedit, verilog, vhdl, vim, visualfoxpro, visualprolog, whitespace, whois, winbatch, xbasic, xhtml, xml, xorg_conf, xpp, yaml, z80, zxbasic


If that works then the mod is installed correctly, if not then the mod has not been installed correctly.

Which 3 files did you alter?
Movie Quote:
It's not the years honey, it's the mileage...
phpBB 3 Mods @ phpBBStyles
<<

lol

Very New Member
Very New Member

Posts: 4

Joined: Wed Dec 15, 2010 2:41 pm

Post Wed Dec 15, 2010 7:12 pm

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Useless hello,

Thank you for taking the time to answer me.

I modified these files:

language/en/common.php
styles/prosilver/template/overall_header.html
styles/prosilver/theme/stylesheet.css

Exactly as specified in the install.xml file

I said that I have refreshed the cache and the theme

  Code:
[version /]
does not work, I tried.

I left all the default settings in phpBB (especially language) because I saw there the file language/en/common.php to change; So I left English.

I do not understand why it does not work, and I do not know how to find the error, perhaps the "debug" mode of phpBB?
<<

lol

Very New Member
Very New Member

Posts: 4

Joined: Wed Dec 15, 2010 2:41 pm

Post Thu Dec 16, 2010 8:36 am

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Hello,

Some improvements ...
I upgraded my phpbb 3.05 to 3.08.

Functions:
  Code:
[syntax=some code]some code[/syntax]

works

But the code
  Code:
[version /]
gives this error in apache logs when I submit post (and I get a blank page):
  Code:
PHP Fatal error:  Call to undefined method GeSHi::get_version() in /var/www/phpBB3/includes/hooks/hook_syntax_highlighter.php on line 284


What I do not understand:
On a fresh installation of phpBB 3.08 it does not work at all. And on a version 3.05 upgraded to 3.08 it works (almost ...)
<<

UseLess

User avatar

Village Idiot
Village Idiot

Posts: 272

Joined: Thu Jan 08, 2009 9:57 pm

Location: North East UK

Post Thu Dec 16, 2010 9:48 am

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Greetings,

The error about the undefined method get_version() means there is a missing function, think it's a function I missed from 1.0.12, so you have 2 choices:

1. Upgrade to 1.0.14, details here: viewtopic.php?f=5&t=91
2. Add the missing function, there's info on that around here somewhere, if I find it I'll edit this post...
Movie Quote:
It's not the years honey, it's the mileage...
phpBB 3 Mods @ phpBBStyles
<<

lol

Very New Member
Very New Member

Posts: 4

Joined: Wed Dec 15, 2010 2:41 pm

Post Thu Dec 16, 2010 1:38 pm

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Hello,

No need to give me the link, I already read half of your forum looking for information ... And for a French, it's tiring :lol:

I did everything again ... :oops:

Because phpBB that I have to install the mod in, is already in 3.08.

So, fresh install of 3.08 + Syntax Highliter 1.0.14a = it works

The annoying thing is that you're angry with AutoMod (not because I like it, but because phpBB gonna make trouble to integrate your updates ...) ;)

I'll install the mod on the forum which is online here: http://aptosid-fr.org/forum/

I suppose that before any update of phpBB I should come round here to verify that the mod will not cause trouble?

Thank you for your help.
<<

Gizmor

Very New Member
Very New Member

Posts: 2

Joined: Wed Jan 12, 2011 12:41 pm

Post Wed Jan 12, 2011 12:53 pm

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Hello!

I tried to install this mod into my phpbb3 (3.0.8). I did everything exactly as stated inside the install.xml.
But none of the BBCodes get parsed. Is there anything else I need to do? Is there an other mod required?

Bye
Gizmor
<<

UseLess

User avatar

Village Idiot
Village Idiot

Posts: 272

Joined: Thu Jan 08, 2009 9:57 pm

Location: North East UK

Post Wed Jan 12, 2011 2:19 pm

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Greetings,

What BBCode are you using?

  Code:
[syntax]<some code>[/syntax]


or have you made the changes to allow the use of [<language>] ... [/<langauge>] ?
Movie Quote:
It's not the years honey, it's the mileage...
phpBB 3 Mods @ phpBBStyles
<<

Gizmor

Very New Member
Very New Member

Posts: 2

Joined: Wed Jan 12, 2011 12:41 pm

Post Wed Jan 12, 2011 2:34 pm

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

tried all:
  Code:
[syntax]<some code>[/syntax]
[syntax="php"]<?php echo true; ?>[/syntax]
[version /]
[php]<?php echo true; ?>[/php]


But nothing happens. $auto_add_tags is true in hook_syntax_highlighter.php


Edit:
I found the problem.
A Quote:
Clear the cache by logging into your Admin Control Panel and clicking "Run now" next to "Purge the cache".

This tip from an other mod fixed the problem. Haven't seen this option before. I only refreshed the cache for the theme/style, since I didn't know there are two ways to clear the cache.

Now it works. Sorry for disturbing :)
<<

UseLess

User avatar

Village Idiot
Village Idiot

Posts: 272

Joined: Thu Jan 08, 2009 9:57 pm

Location: North East UK

Post Wed Jan 12, 2011 4:26 pm

Re: [MODDB] phpBB Syntax Highlighter - 1.0.12

Greetings,

Depending on the style you're using the style/theme data isn't stored in the cache it's in the database which is why you need to refresh it, I "think" there's an option somewhere to do it automatically.

But happy you got it sorted in the end..
Movie Quote:
It's not the years honey, it's the mileage...
phpBB 3 Mods @ phpBBStyles
Previous

Return to phpBB 3 Mods

Who is online

Users browsing this forum: No registered users and 2 guests

cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for blacklist.org.